HomeContac UsProductsPricingDemos/UpdatesDownloadsSupportRegisterSpecial OffersPress ReleasesMiscellaneousSearch

 
Lion Mac OS X 10.7 and Mountain Lion Mac 10.8 and Mavericks 10.9 and Yosemite 10.10 and El Capitan 10.11 and Sierra 10.12 and High Sierra 10.13 and Mojave 10.14
ITW is marginal under Mojave, but better with 10.14.3.
Coming soon -- Information on the future of ITW and suggestions.
 
GENERAL - It appears that most software will need to be upgraded, or at least updated, for Lion and beyond. This includes all of our software.
Yes, we're working on it, but what caused us to have a problem?
Click here.
 
Why is it taking so long? The cause of the problem, explained above, caused a severe financial problem. These have been bad years to get a bank loan. We have been working our way back to financial health. We are now about at that point.

When will new versions be available? When we know the answer, we will post it here. Please do not e-mail us with this question.

WE HAVE SOME GOOD NEWS ON ITW WITH EL CAPITAN.

SPECIFIC - These specific messages apply to Lion, Mountain Lion, Mavericks, Yosemite, El Capitan, and Sierra.

CalendarMaker 5.0.7 will
NOT work under Lion or any more recent operating system. Your calendar files may be irreparably damaged when you try to Save. (Not always the first time, or even the second -- but eventually you lose all your work.)

InTouch With 3.1.3 will work under Lion through High Sierra depending on the circumstances.
Click here for important information -- especially with El Capitan beginning with 10.11.2 and how Sierra (and High Sierra) was a step backwards.

QuickProject will NOT work under Lion. It is still PowerPC and requires Snow Leopard and prior.

This news section is updated regularly as we have more information. This news section was last updated as of Sep. 25, 2017, with a minor update on Feb. 22, 2019.